My Nikon Coolpix L810 won't turn on?

My l810 was working perfectly until yesterday. When I turned it on, the lens came out, and the light turned on for about 5 seconds, the lcd screen never lit up, and the camera appeared to be off with the lens still out. Now, when I press the power button, the light goes on for about 5 seconds, and nothing happens. I have tried replacing batteries, plugging it into the PC, and plugging it in to the TV. Is there a way to fix this?

I'd contact Nikon as a last resort.

Remember, digital cameras EAT alkalines - the only disposables that will give you anything like a decent working life are the (expensive) Lithium. Your best bet is rechargeable Ni-Mh types, they're expensive to start with, but pay for themselves in the long run

Connecting your camera to your TV or computer isn't going to help at all… Because you NEED battery power to run your camera. Your camera could either have a lens error or other problem, but I'm guessing that you're not using good enough batteries. You need really good batteries to power your camera… Not cheap alkalines. Rechargeable NiMH batteries provide more power (and are much more cost effective in the long run) or you could use non rechargeable Lithium, such as Energizer Ultimate. They're expensive though, but perfect as a backup or when you have no access to electricity to recharge your NiMH batteries.

Don't forget that if you do change over to rechargeable AA NiMH or Lithium batteries… You're meant to set which battery type you are currently using… By changing the battery type in your camera's Setup Menu. Page 11 of your User's Manual (very bottom of the page) explains this. Nikon says this helps the batteries perform more efficiently.

Had the same problem. Fixed by buying good duracel batterries. Sorted Phew!

Mine is having exactly the same problem despite having brand new batteries in it!

I have the same problem and have tried everything I could find as a suggestion. The lens is out, the camera won't turn on, I'm frustrated! Any answers?